Some troubles with encoding while Russian Language localization

  • 216 Views
  • Last Post 08 November 2015
  • Topic Is Solved
Rei Ken posted this 04 November 2015

I found this bug:

bug litera m

There is for litera "М" in russian.

And so I get this view on my site:
m

 

How to fix this?

Order By: Standard | Newest | Votes
YodasMyDad posted this 04 November 2015

How did you add the Russian language? Did you manually change the language keys one by one?

Rei Ken posted this 04 November 2015

I added Russian language:

... And then manually changed language keys one by one.

YodasMyDad posted this 05 November 2015

Hmmm ok that's weird. I'll add it to my list to investigate.

blteblte posted this 06 November 2015

I found this same issue for category names (Enlish language as forum lng in use atm.):

If you enter the category name in Russian (or sub-cat - whatever) the russian "M" or "m" gets replaced.

You will see the propper leter in category tree, but in every select you'll have this html literal.

 

Try to name the category like: "Форум" - and you'll see that

Rei Ken posted this 06 November 2015

Does anybody know how to fix this bug?

YodasMyDad posted this 07 November 2015

Thanks @blteblte. I'll use this to test with on my machine

YodasMyDad posted this 08 November 2015

I have used Форум in the categories on my local machine and it works fine? It's also fine in the select dropdowns? Just about to try in the language strings.

YodasMyDad posted this 08 November 2015

Actually found the issue with the encoding. It's Microsofts XSSSanitiser library doing it.

Close